All systems seem to be working fine and at capacity. We are continuing to monitor for any issues.
Posted Oct 30, 2023 - 16:53 EDT
Update
Our website frontends have recovered thanks to Cloudflare resolving its issues. Our API backend is now struggling to catch up to the traffic and is responding slowly for many users. We're scaling back up but should back to full speed soon.
Posted Oct 30, 2023 - 16:40 EDT
Update
We are continuing to investigate the issue.
Posted Oct 30, 2023 - 16:26 EDT
Investigating
Due to issues with our infrastructure provider Cloudflare, we have a major service outage of our website frontends for admins, teachers and students.
Issues began at 3:53PM EST and are still being investigated by Cloudflare at 4:07pm EST. We will update here as soon as we have recovered.